android build 하다가


Can't locate Switch.pm in @INC (you may need to install the Switch module) 어쩌구 저쩌구 나올 때 해결하는 방법


perl 5.14 이후 Switch 모듈이 제거되면서 발생하는 에러다.

Ubuntu14.04 에는 기본적으로 perl5.18 이 설치되어 있어서 그런데 아래와 같이 하면 된다.


먼저 libswitch-perl 를 깔고

$ sudo apt-get install libswitch-perl



cpan을 실행.

$ cpan


뭔 설정 한다고 나오는데 대충 엔터한다음


cpan[1]> 라는 프롬프트가 뜨면 됨


install Switch 라는 명령어로 switch 설치


cpan[1]> install Switch


다 깔았으면 exit 치고 나가면 

Posted by Real_G